請不要在系統中同時裝兩套以上的Ruby+Rubygem

…爛掉好幾次..

廣告

請不要在系統中同時裝兩套以上的Ruby+Rubygem” 有 2 則迴響

  1. 我裝過四套…? XD
    1. mac 內建
    2. 1.8.7
    3. 1.9.1 (suffix 19)
    4. JRuby (prefix j)
    其實是還好 XD
    不過如果要用 gem 裡的 bin 的話,
    可能會要有兩種解法:
    1. 例如 jruby `which ramaze` 來選擇 ruby 版本
    2. gemrc 裡面加上 –format-executable
    這樣你的 jruby 版 ramaze 就會是 jramaze,
    1.9.1 版可能就是 ramaze19
    但是 1.9.1 目前的 gem prelude 有 bug,
    用 user gem 可能會有點問題,這點要小心

發表迴響

在下方填入你的資料或按右方圖示以社群網站登入:

WordPress.com Logo

您的留言將使用 WordPress.com 帳號。 登出 / 變更 )

Twitter picture

您的留言將使用 Twitter 帳號。 登出 / 變更 )

Facebook照片

您的留言將使用 Facebook 帳號。 登出 / 變更 )

Google+ photo

您的留言將使用 Google+ 帳號。 登出 / 變更 )

連結到 %s